Commit f6dbdafa authored by Médéric Boquien's avatar Médéric Boquien

Upgrade the minimum python version to 3.6

parent 756f8f3f
...@@ -4,6 +4,7 @@ ...@@ -4,6 +4,7 @@
### Added ### Added
- The (1+z1)/(1+z2) factor between observed and grid flux densities caused by the differential redshifting is now taken into account. With a default grid redshift rounding of two decimals this yields a difference of at most 0.5% in the estimated physical properties at z=0 and even less at higher z. (Médéric Boquien) - The (1+z1)/(1+z2) factor between observed and grid flux densities caused by the differential redshifting is now taken into account. With a default grid redshift rounding of two decimals this yields a difference of at most 0.5% in the estimated physical properties at z=0 and even less at higher z. (Médéric Boquien)
### Changed ### Changed
- Python 3.6 is now the minimum required version. (Médéric Boquien)
- The logo has now been moved to the lower-right corner of the figure so that it does not overlap with any information and it has been updated for a less pixelated version. (Médéric Boquien & Rodrigo González Castillo) - The logo has now been moved to the lower-right corner of the figure so that it does not overlap with any information and it has been updated for a less pixelated version. (Médéric Boquien & Rodrigo González Castillo)
- The wavelength range in SED plots is now dynamically adapted to cover the observed wavelengths. (Médéric Boquien) - The wavelength range in SED plots is now dynamically adapted to cover the observed wavelengths. (Médéric Boquien)
### Fixed ### Fixed
......
...@@ -54,12 +54,9 @@ def run(config): ...@@ -54,12 +54,9 @@ def run(config):
def main(): def main():
if sys.version_info[:2] < (3, 5):
raise Exception("Python {}.{} is unsupported. Please upgrade to "
"Python 3.5 or later.".format(*sys.version_info[:2]))
if sys.version_info[:2] < (3, 6): if sys.version_info[:2] < (3, 6):
print("Python {}.{} detected. For better performance we recommend " raise Exception("Python {}.{} is unsupported. Please upgrade to "
"Python 3.6 or later.".format(*sys.version_info[:2])) "Python 3.6 or later.".format(*sys.version_info[:2]))
# We set the sub processes start method to spawn because it solves # We set the sub processes start method to spawn because it solves
# deadlocks when a library cannot handle being used on two sides of a # deadlocks when a library cannot handle being used on two sides of a
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment