Commit ad701268 authored by PENGUEN Julien's avatar PENGUEN Julien

mise à jour pour compatibilité avec construction d'un wheel

parent ef06f614
......@@ -47,3 +47,5 @@ __pycache__/
*~
.coverage
.cache
wheelhouse/*
build/*
include etc42/etc42/Dockerfile
include etc42/etc42/etc42.conf
......@@ -11,7 +11,6 @@ import time
import argparse
import docker
from io import BytesIO
import pytest_docker_tools
from etc42.etc42.etc42 import *
def test_get_args_from_file():
......
[aliases]
test=pytest
[bdist_wheel]
universal = 1
import sys
__minimum_python_version__ = '3.5.2'
if sys.version_info < tuple((int(val) for val in __minimum_python_version__.split('.'))):
sys.stderr.write("ERROR: etc42 requires Python {} or later\n".format(
__minimum_python_version__))
sys.exit(1)
import os
from setuptools import setup, find_packages
NAME = 'etc42' #PEP 508
VERSION = '0.0.0' #PEP 440
VERSION = '1.0.11' #PEP 440
# Add any necessary entry points
entry_points = {}
# Command-line scripts
......@@ -27,9 +19,9 @@ setup(name=NAME,
author='The LAM ETC42 developers',
license='GPLv3',
packages=find_packages(),
requires=['docker'],
requires= [],
setup_requires=[],
install_requires=[],
install_requires = [ 'docker>=2.0.0', 'wget>=1.0'],
classifiers=[
'Development Status :: 1 - Planning',
'Intended Audience :: Science/Research',
......@@ -41,6 +33,5 @@ setup(name=NAME,
],
include_package_data=True,
entry_points=entry_points,
python_requires='>=' + __minimum_python_version__,
tests_require=['pytest']
)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment